Site Issues
Incident Report for Etsy
Resolved
We think the impact from the issue is over.
Posted Sep 29, 2023 - 17:59 UTC
Monitoring
We've deployed a fix and are monitoring the recovery.
Posted Sep 29, 2023 - 17:15 UTC
Investigating
We are currently experiencing an issue and are investigating.
Posted Sep 29, 2023 - 16:09 UTC