Site Issues
Incident Report for Etsy
Resolved
We've addressed and closed this issue, but will continue to monitor.
Posted Jan 12, 2024 - 03:03 UTC
Update
We are still currently experiencing an issue and are continuing our investigation
Posted Jan 12, 2024 - 02:32 UTC
Update
We are still currently experiencing an issue and are continuing our investigation
Posted Jan 12, 2024 - 02:04 UTC
Update
We are currently experiencing an issue and are investigating.
Posted Jan 12, 2024 - 01:39 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jan 12, 2024 - 01:34 UTC