Site slowness
Incident Report for Etsy
Resolved
We think the impact from the issue is over.
Posted Mar 28, 2023 - 11:42 UTC
Investigating
We've spotted that some operations are taking longer than expected. We're currently investigating the issue, and will provide an update soon.
Posted Mar 28, 2023 - 11:26 UTC