Search Issues
Incident Report for Etsy
Resolved
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Sep 19, 2023 - 04:18 UTC
Monitoring
We have deployed a fix and are monitoring our systems.
Posted Sep 19, 2023 - 02:54 UTC
Update
We continue to investigate and will provide an update soon.
Posted Sep 19, 2023 - 02:19 UTC
Investigating
We've spotted that something has gone wrong with our search. We're currently investigating the issue, and will provide an update soon.
Posted Sep 19, 2023 - 01:32 UTC