We're experiencing an issue with seller video uploads
Incident Report for Etsy
Resolved
This incident has been resolved.
Posted May 30, 2023 - 04:19 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted May 30, 2023 - 01:46 UTC