Listing Manager Issue
Incident Report for Etsy
Resolved
The Listing Manager is working correctly again.
Posted Sep 27, 2023 - 20:13 UTC
Identified
We've spotted that something has gone wrong with the Listing Manager. We're currently fixing the issue, and will provide an update soon.
Posted Sep 27, 2023 - 19:55 UTC