Site Issues
Incident Report for Etsy
Resolved
This incident has been resolved. If you are still experiencing an issue, please let us know in our Etsy Forums (https://community.etsy.com/t5/Technical-Issues/bd-p/bugs).
Posted Oct 25, 2022 - 15:58 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 25, 2022 - 15:34 UTC
Investigating
We are currently experiencing an issue and are investigating.
Posted Oct 25, 2022 - 15:31 UTC