Issue impacting search
Incident Report for Etsy
Resolved
This incident has been resolved. If you are still experiencing an issue, please let us know in our Etsy Forums.
Posted Oct 18, 2022 - 10:10 UTC
Investigating
We are currently investigating an issue with search, and will provide an update soon.
Posted Oct 18, 2022 - 09:12 UTC