Authentication Issues
Incident Report for Etsy
Resolved
We think the impact from the issue is over.
Posted Mar 30, 2023 - 19:44 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Mar 30, 2023 - 19:09 UTC