checkout issues
Incident Report for Etsy
Resolved
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Dec 19, 2023 - 00:26 UTC
Monitoring
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Dec 19, 2023 - 00:09 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Dec 19, 2023 - 00:03 UTC